You signed in with another tab or window. Reload to refresh your session.You signed out in another tab or window. Reload to refresh your session.You switched accounts on another tab or window. Reload to refresh your session.Dismiss alert
{{ message }}
Repository navigation
Ubuntu-26.04 does not have builds of Ruby <= 3.1 #954
GitHub now rolling ubuntu-latest from 24.04 to 26.04.
As a result, workflows that have been assigned to a 26.04 runner are failing to install Ruby using setup-ruby.
Are you using a ruby version that's not the latest patch version on any current supported branch?
Otherwise, if you're using a supported ruby version but it still fails, can you please post a link to failed workflow or provide the config options you are using for setup-ruby?
Even the latest patches of Ruby 3.1 and older, such as 3.1.7, are missing on ubuntu-26.04 because they fail to build with GCC 15 there. ruby/ruby-builder#31 adds the flags to build them.
Ruby 2.4 - 3.1 (latest patch releases only, so that's ruby-2.4.10, ruby-2.5.9, ruby-2.6.10, ruby-2.7.8, ruby-3.0.7, ruby-3.1.7) are now built on ubuntu-26.04 and are being added to CI in #961.
Thank you @hsbt for the help with ruby/ruby-builder#31 and @Earlopain for investigating this back in #922.
I didn't realize back then the potential issue with workflows failing once ubuntu-latest changes from 24.04 to 26.04, my bad.
I will not build Ruby 2.3 and older, even OpenSSL fails to link, and Ruby 2.2 didn't build on 24.04 either, and they require workarounds which seem less reasonable and more risky.
See ruby/ruby-builder#31 for details
Activity
ntkme commentedon Oct 22, 2026
Please see this comment: #943 (comment)
Are you using a ruby version that's not the latest patch version on any current supported branch?
Otherwise, if you're using a supported ruby version but it still fails, can you please post a link to failed workflow or provide the config options you are using for
setup-ruby?hsbt commentedon Oct 31, 2026
Even the latest patches of Ruby 3.1 and older, such as 3.1.7, are missing on
ubuntu-26.04because they fail to build with GCC 15 there. ruby/ruby-builder#31 adds the flags to build them.[-]Packages for ubuntu-26.04[/-][+]Ubuntu-26.04 does not have builds of Ruby <= 3.1[/+]eregon commentedon Oct 31, 2026
Thanks for raising this.
With the default changing I agree we should try to fix this ASAP.
eregon commentedon Oct 31, 2026
Previous discussion on this: #922 (comment)
eregon commentedon Oct 31, 2026
Ruby 2.4 - 3.1 (latest patch releases only, so that's
ruby-2.4.10, ruby-2.5.9, ruby-2.6.10, ruby-2.7.8, ruby-3.0.7, ruby-3.1.7) are now built on ubuntu-26.04 and are being added to CI in #961.Thank you @hsbt for the help with ruby/ruby-builder#31 and @Earlopain for investigating this back in #922.
I didn't realize back then the potential issue with workflows failing once
ubuntu-latestchanges from 24.04 to 26.04, my bad.I will not build Ruby 2.3 and older, even OpenSSL fails to link, and Ruby 2.2 didn't build on 24.04 either, and they require workarounds which seem less reasonable and more risky.
See ruby/ruby-builder#31 for details
ci: use ubuntu-24.04 for Ruby 2.3 or older
eregon commentedon Nov 3, 2026
Update: 2.3.8 is also supported now thanks to rbenv/ruby-build#2651.